Back
Degraded

Smart and Globe Loading stability issue

Started 19 Sep at 05:10pm CST, resolved 19 Sep at 06:00pm CST.

eLoading
Resolved

Smart and Globe Loading online

Posted 19 Sep at 06:00pm CST.
Created

Smart and Globe loading is currently experiencing a delay in transactions. Kindly contact Customer Service for support and inquiries.

Posted 19 Sep at 05:10pm CST.