Back
Degraded

Globe Loading Offline

Started 22 Oct at 06:57pm CST, resolved 24 Oct at 08:49pm CST.

eLoading
Resolved

Globe Loading is now online and restored. You may proceed to your transactions.

Posted 24 Oct at 08:49pm CST.
Created

Globe loading unavailable due to telco problem

Posted 22 Oct at 06:57pm CST.