Back
Maintenance

Globe Scheduled Maintenance

Completed 18 Jan at 03:00am CST.

eLoading
Completed

Maintenance completed

Posted 18 Jan at 03:00am CST.
Started

Globe Telecom will conduct system maintenance on January 18, from 12:30 AM to 3:00 AM. To avoid convenience, we suggest that you perform transactions before the activity starts.

Posted 18 Jan at 12:00am CST.