Back
Degraded

Paymaya Sending Unavailable

Started 21 Jan at 10:26am CST, resolved 1 Feb at 09:55am CST.

Resolved

Issue resolved

Posted 1 Feb at 09:55am CST.
Created

Paymaya Sending is unavailable until further notice due to technical issue. We are currently fixing the issue, kindly contact Customer Service for inquiries.

Posted 21 Jan at 10:26am CST.