Back
Maintenance

Ecpay Bills Payment Maintenance

Completed 5 May at 06:00am CST.

Bills Payment
Completed

Maintenance completed

Posted 5 May at 06:00am CST.
Started

We would like to inform everyone that our Bills Payment partner will undergo scheduled maintenance from May 5, 01:00 AM to 6:00 AM. This is to enhance the reliability and performance, and to ensure the continuous delivery of the highest quality of service to our customers.

We apologize for any inconvenience this may cause and appreciate your patience and understanding during this time. If you have any questions or concerns, please do not hesitate to contact our customer support team at www.fb.com/loadmannacustomerservice.

Posted 5 May at 01:00am CST.