Back
Maintenance

System Maintenance
Completed 18 May at 01:00am CST.
Login Service
member.loadmanna.com
Completed
Maintenance completed
Posted
18 May at 01:00am CST.

Started
We would like to inform everyone that our Loadmanna apps V3.5, member.loadmanna.com and shop.loadmanna.ph will have a scheduled maintenance from May 17 11:00 PM to May 18 1:00 AM. The maintenance is necessary to improve the reliability and performance of our network infrastructure, and to ensure that we continue to deliver the highest quality of service to our customers.
If you have any questions or concerns, please do not hesitate to contact our customer support team at Customer Service via the app or our Customer Service Facebook page.
Thank you for your understanding and support, Ka Loadmanna.
Posted
17 May at 11:00pm CST.