Back
Resolved

Traditional Loading Offline

Started 5 Jun at 04:27pm CST.

eLoading
Created

We are happy to inform you that our Traditional Loading has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 5 Jun at 04:27pm CST.