Back
Resolved

Instapay Cash-out
Started 20 Oct at 09:45pm CST.
Created
We are happy to inform you that our Cash-Out via Instapay service has been fully restored and is now back to full functionality. You may now proceed with your transactions.
Thank you for your support and patience, Ka Loadmanna!
Posted 20 Oct at 09:45pm CST.