Back
Resolved

Cash in & Cash Out via Instapay Maintenance

Started 1 Dec at 03:20pm CST.

Wallet Server
Created

We are happy to inform you that our Cash in & Cash out has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 1 Dec at 03:20pm CST.