Back
Resolved

Meralco Bills Payment Maintenance

Started 6 Dec at 09:40pm CST.

Bills Payment
Created

We are happy to inform you that our Meralco Bills Payment partner has fully restored and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 6 Dec at 09:40pm CST.