Back
Degraded

Billers Temporarily Unavailable
Started 10 Jan at 03:44pm CST, resolved 11 Jan at 10:37am CST.
Bills Payment
Resolved
We are happy to inform you that our payment partner has been completely restored and is now fully functional. You can now proceed with your transactions. The following billers are available for payment:
Meralco
Maynilad
Gcash
Thank you for your continued support and patience, Ka Loadmanna!
Posted 11 Jan at 10:37am CST.

Created
We regret to inform you that our Bills Payment service is currently experiencing network stability issues. The following billers are temporarily unavailable:
Meralco
Maynilad
Homecredit
Gcash
We apologize for any inconvenience this may cause and we will update you as soon as we have more information.
Posted 10 Jan at 03:44pm CST.