Back
Maintenance

Downtime for Globe E-Loading

Completed 21 Jan at 06:00am CST.

eLoading
Completed

Maintenance completed

Posted 21 Jan at 06:00am CST.
Started

We will experience downtime for our e-loading services from Globe Telecom due to their system maintenance. Time frame of the downtime is from January 20, 11 PM to January 21 6 AM.

Posted 20 Jan at 11:00pm CST.