Back
Maintenance

Scheduled Billspayment System Maintenance
Completed 4 Feb at 04:00am CST.
Bills Payment
Completed
Maintenance completed
Posted
4 Feb at 04:00am CST.

Started
We would like to inform you that our partner, ECPay (Bills payment), will undergo a scheduled system maintenance on February 4, 2024, from 2:00 AM to 4:00 AM. Kindly note that all billers on ECPay will be unavailable during this period.
We sincerely apologize for any inconvenience this may cause and greatly appreciate your understanding. Thank you for your cooperation and continued support.
Posted
4 Feb at 02:00am CST.