Back
Resolved

Offline Conversion Mannawallet to Loadwallet

Started 21 Feb at 09:22am CST.

Wallet Server
Created

We are happy to inform you that our Conversion of Manna Wallet to Load wallet has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 21 Feb at 09:22am CST.