Back
Downtime

Emergency Maintenance
Started 8 Mar at 07:15pm CST, resolved 8 Mar at 08:39pm CST.
Central Server
Bills Payment
eLoading
Login Service
Wallet Server
member.loadmanna.com
LMRP
Resolved
We are happy to inform you that all our services is now online 03/08/2024 8:35pm (Friday). Sorry for the inconvenience. You may now proceed to your transactions.
Thank you for your support and patience, Ka-Loadmanna!
Posted 8 Mar at 08:39pm CST.

Created
We regret to inform you that all our services is currently undergoing Emergency Maintenance.
We apologize for any inconvenience this may cause and we will update you as soon as we have more information.
Posted 8 Mar at 07:15pm CST.