Back
Resolved

Bills Payment Temporarily Unavailable

Started 25 Mar at 10:15am CST.

Bills Payment
Created

We are happy to inform you that our Bills payment partner has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 25 Mar at 10:15am CST.