Back
Maintenance

Smart Telecom Maintenance

Completed 22 May at 08:00am CST.

eLoading
Completed

Maintenance completed

Posted 22 May at 08:00am CST.
Started

We would like to inform you that our partner, Smart Telecom, will undergo scheduled system maintenance on:

May 21, 2024, 8:00 PM to May 22, 2024, 8:00 AM

Kindly note that all transactions with Smart will be unstable during this period.

We sincerely apologize for any inconvenience this may cause and greatly appreciate your understanding.
Thank you for your cooperation and continued support.

Posted 21 May at 08:00pm CST.