Back
Degraded

Bills payment Temporarily unavailable

Started 2 Jun at 08:04pm CST, resolved 3 Jun at 10:16am CST.

Bills Payment
Resolved

We are happy to inform you that our Bills Payment has been fully restored and is now back to full functionality. You may now proceed with your transactions.

Thank you for your support and patience, Ka Loadmanna!

Posted 3 Jun at 10:16am CST.
Created

We regret to inform you that our Bills Payment is currently experiencing stability issues. Our team is working closely with our partner to resolve the issue as soon as possible.

We apologize for any inconvenience this may cause and we will update you as soon as we have more information.

Posted 2 Jun at 08:04pm CST.