Back
Degraded

Offline Meralco Flexi

Started 12 Jul at 12:59pm CST, resolved 13 Jul at 01:11pm CST.

Bills Payment
Resolved

We are happy to inform you that our Meralco Flexi Biller has been fully restored and is now back to full functionality. You may now proceed with your transactions.

Thank you for your support and patience, Ka Loadmanna!

Posted 13 Jul at 01:11pm CST.
Created

We regret to inform you that our Meralco Flexi Biller is currently experiencing stability issues. Our team is working closely with our partner to resolve the issue as soon as possible.

We apologize for any inconvenience this may cause and we will update you as soon as we have more information.

Posted 12 Jul at 12:59pm CST.