Back
Resolved

Bills payment is unavailable

Started 19 Jul at 06:52pm CST.

Bills Payment
Created

Bills payment services has been affected by the ongoing large scale IT outage.

Posted 19 Jul at 06:52pm CST.