Back
Resolved

Experiencing Delay in Online Eloading via Mobile Application
Started 11 Nov at 12:30pm CST.
eLoading
Created
We regret to inform you that our loading service is currently experiencing a network stability issue, which may cause online transactions made via the mobile application to take a few minutes to process or potentially fail. Our team is working to resolve the issue as soon as possible.
We apologize for any inconvenience this may cause and will provide updates as soon as more information becomes available.
Posted 11 Nov at 12:30pm CST.