Back
Maintenance

Scheduled System Maintenance
Completed 18 Jan at 04:00am CST.
Bills Payment
Login Service
Wallet Server
member.loadmanna.com
Completed
Maintenance completed
Posted
18 Jan at 04:00am CST.

Started
We would like to inform everyone that from 11:00 PM to 4:00 AM, our Loadmanna apps v4.8 (Android, iOS, and web) as well as online transactions will undergo scheduled maintenance.
This maintenance is necessary to improve the reliability and performance of our network infrastructure, ensuring we continue to deliver the highest quality of service to all our customers.
Members will still be able to transact via messenger loading and offline eloading
If you have any questions or concerns, please do not hesitate to contact our customer support team at Customer Service via the app or our Customer Service Facebook page.
Thank you for your understanding and support, Ka Loadmanna.
Posted
17 Jan at 11:00pm CST.