Back
Downtime

Billspayment Temporarily Unavailable

Started 5 Feb at 07:51pm CST, resolved 6 Feb at 11:00am CST.

Bills Payment
Resolved

We are happy to inform you that our Bills payment has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 6 Feb at 11:00am CST.
Created

Hello Ka-Loadmanna! We regret to inform you that our Bills Payment is temporarily unavailable due to stability issues. Our team is working closely with our biller partners to resolve the issue as soon as possible.

We apologize for any inconvenience this may cause, and we will update you as soon as we have more information.

Posted 5 Feb at 07:51pm CST.