Back
Resolved

DITO Loading Services (Unavailable)
Started 6 Feb at 05:31pm CST, last updated 6 Feb at 07:00pm CST.
eLoading
Updated
We are happy to inform you that our DITO Loading service has been successfully restored and is now fully functional. You may now continue to your transactions.
Thank you for your support & patience, Ka Loadmanna!
Posted 6 Feb at 07:00pm CST.
Created
We regret to inform you that our DITO Loading is currently experiencing a network stability issue. Our team is working closely with the telco to resolve the issue as soon as possible.
We apologize for any inconvenience this may cause and we will update you as soon as we have more information.
Posted 6 Feb at 05:31pm CST.