Back
Downtime

Billspayment Temporarily Unavailable

Started 1 Apr at 05:43pm CST, resolved 2 Apr at 05:26pm CST.

Bills Payment
Resolved

We are happy to inform you that our Bills payment has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 2 Apr at 05:26pm CST.
Created

We regret to inform you that our Bills Payment service is currently experiencing stability issues. Our team is working closely with our partner to resolve the issue as soon as possible.

We apologize for any inconvenience this may cause, and we will update you as soon as we have more information.

Posted 1 Apr at 05:43pm CST.