Back
Downtime

Billspayment Maintenance

Started 22 Apr at 06:23pm CST, resolved 23 Apr at 12:21pm CST.

Bills Payment
Resolved

We are happy to inform you that our Bills payment has fully restored their services and is now back to full functionality. You may now continue to your transactions.

Thank you for your support & patience, Ka Loadmanna!

Posted 23 Apr at 12:21pm CST.
Created

We regret to inform you that our Bills Payment service is currently unavailable due to undergoing maintenance. Our team is working closely with our partner to resolve the issue as soon as possible.

We apologize for any inconvenience this may cause, and we will update you as soon as we have more information.

Posted 22 Apr at 06:23pm CST.