Back
Degraded

Paymaya Negosyo Sending is currently offline
Started 26 Apr at 07:57am CST, resolved 26 Apr at 10:39am CST.
Resolved
Paymaya Negosyo Sending is now available. You may now process your TR transactions.
Posted 26 Apr at 10:39am CST.

Created
Paymaya Negosyo Sending is currently offline due to technical issues. Kindly wait for further update. Thank you for your patience.
Posted 26 Apr at 07:57am CST.